summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2018-12-04 16:59:01 +0100
committerMarcel Holtmann <marcel@holtmann.org>2018-12-04 17:21:08 +0100
commit0093cd61b1e4f199bca45f8c2f8eb2d5a30e847d (patch)
tree7ba152e499d7ca0f1ae2cfbb73983a8ffbb09e7a /configure.ac
parent8eda0a753507903a13af27a69df19cddf9bec23f (diff)
downloadbluez-0093cd61b1e4f199bca45f8c2f8eb2d5a30e847d.tar.gz
build: Add support for internal and external ELL configuration
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ee4199f4d..f46e38122 100644
--- a/configure.ac
+++ b/configure.ac
@@ -248,13 +248,20 @@ AC_ARG_ENABLE(btpclient, AC_HELP_STRING([--enable-btpclient],
[enable BTP client]), [enable_btpclient=${enableval}])
AM_CONDITIONAL(BTPCLIENT, test "${enable_btpclient}" = "yes")
-if (test "${enable_btpclient}" = "yes" || test "${enable_mesh}" = "yes"); then
- PKG_CHECK_MODULES(ELL, ell >= 0.14, enable_ell=yes,
- AC_MSG_ERROR(ell library >= 0.14 is required))
+AC_ARG_ENABLE([external_ell], AC_HELP_STRING([--enable-external-ell],
+ [enable external Embedded Linux library]),
+ [enable_external_ell=${enableval}])
+if (test "${enable_external_ell}" = "yes"); then
+ PKG_CHECK_MODULES(ELL, ell >= 0.14, dummy=yes,
+ AC_MSG_ERROR(Embedded Linux library >= 0.14 is required))
AC_SUBST(ELL_CFLAGS)
AC_SUBST(ELL_LIBS)
fi
-AM_CONDITIONAL(ELL, test "${enable_ell}" = "yes")
+AM_CONDITIONAL(EXTERNAL_ELL, test "${enable_external_ell}" = "yes" ||
+ (test "${enable_btpclient}" != "yes" &&
+ test "${enable_mesh}" != "yes"))
+AM_CONDITIONAL(LIBSHARED_ELL, test "${enable_btpclient}" = "yes" ||
+ test "${enable_mesh}" = "yes")
AC_ARG_ENABLE(client, AC_HELP_STRING([--disable-client],
[disable command line client]), [enable_client=${enableval}])