summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSzymon Janc <szymon.janc@codecoup.pl>2018-01-19 16:23:20 +0100
committerSzymon Janc <szymon.janc@codecoup.pl>2018-04-24 10:41:47 +0200
commit07384fa47a27485e1c7294f4372be4068d3a6310 (patch)
treed8eb7c38620fa12482cf393abee645f2be63f364 /configure.ac
parent37a30b5435a45c3f8e233309fc70fc7de92b2e76 (diff)
downloadbluez-07384fa47a27485e1c7294f4372be4068d3a6310.tar.gz
tools: Add initial code for btmon-logger
This is intended for use for automated logging or unatrended systems. It doesn't contain any packet decoding functionality which results in much smaller binary.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index db46d6f07..5132131f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,6 +327,10 @@ AC_ARG_ENABLE(sixaxis, AC_HELP_STRING([--enable-sixaxis],
AM_CONDITIONAL(SIXAXIS, test "${enable_sixaxis}" = "yes" &&
test "${enable_udev}" != "no")
+AC_ARG_ENABLE(logger, AC_HELP_STRING([--enable-logger],
+ [enable HCI logger service]), [enable_logger=${enableval}])
+AM_CONDITIONAL(LOGGER, test "${enable_logger}" = "yes")
+
if (test "${prefix}" = "NONE"); then
dnl no prefix and no localstatedir, so default to /var
if (test "$localstatedir" = '${prefix}/var'); then