summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTedd Ho-Jeong An <tedd.an@intel.com>2023-02-20 10:12:05 -0800
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2023-02-21 14:13:12 -0800
commit1106b28be85ac9586d1758839226e163e9030ee2 (patch)
tree6920f58b4d18de441038f5ae650890f7423c0759 /configure.ac
parent1bfd597fe8817c2cb4c710270f5a82511a9f94f4 (diff)
downloadbluez-1106b28be85ac9586d1758839226e163e9030ee2.tar.gz
configure: Check ell path
If the 'enable-external-ell' is not specified in the configure parameter, the build system assumes that the ELL source is located same level where the bluez source is cloned. But the configure doens't check the folder and user will get the build error while building the source. This patch checks if the ELL source path if the 'enable-external-ell' flag is not set and throws an error if the ELL doesn't exist.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9f0faf57..515cdf146 100644
--- a/configure.ac
+++ b/configure.ac
@@ -289,6 +289,11 @@ if (test "${enable_external_ell}" = "yes"); then
AC_SUBST(ELL_CFLAGS)
AC_SUBST(ELL_LIBS)
fi
+if (test "${enable_external_ell}" != "yes"); then
+ AC_CHECK_FILE(${srcdir}/ell/ell.h, dummy=yes,
+ AC_CHECK_FILE(${srcdir}/../ell/ell/ell.h, dummy=yes,
+ AC_MSG_ERROR(ELL source is required or use --enable-external-ell)))
+fi
AM_CONDITIONAL(EXTERNAL_ELL, test "${enable_external_ell}" = "yes" ||
(test "${enable_btpclient}" != "yes" &&
test "${enable_mesh}" != "yes"))