summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorInga Stotland <inga.stotland@intel.com>2019-12-20 11:13:29 -0800
committerBrian Gix <brian.gix@intel.com>2019-12-24 10:38:34 -0800
commit11d7fe8535be45bb354b71cd6db0b394b3f178d7 (patch)
treededb77445519726cf0708c78ec43793e005dcbc8 /configure.ac
parentffdd4f5817b4f555f98e170bf1312afeb1a15041 (diff)
downloadbluez-11d7fe8535be45bb354b71cd6db0b394b3f178d7.tar.gz
mesh: Base config json code on newer version of json-c
This removes a roundabout logic that was required to delete a json entry from a json array using libjsonc utilities. A new API function, json_object_array_del_idx(), implemented in json-c version 0.13 simplifies array entry removal to one call. Also, add requirement to configure.ac for json-c version >= 0.13
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 57a816fd5..6f7717f24 100644
--- a/configure.ac
+++ b/configure.ac
@@ -230,8 +230,8 @@ AC_ARG_ENABLE(mesh, AC_HELP_STRING([--enable-mesh],
AM_CONDITIONAL(MESH, test "${enable_mesh}" = "yes")
if (test "${enable_mesh}" = "yes"); then
- PKG_CHECK_MODULES(JSONC, json-c, dummy=yes,
- AC_MSG_ERROR(json-c is required))
+ PKG_CHECK_MODULES(JSONC, json-c >= 0.13, dummy=yes,
+ AC_MSG_ERROR(json-c >= 0.13 is required))
AC_SUBST(JSON_CFLAGS)
AC_SUBST(JSON_LIBS)
fi