summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAbhay Maheta <abhay.maheshbhai.maheta@intel.com>2022-10-18 10:08:30 +0530
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2022-10-18 13:11:56 -0700
commit123e1ee1ce063af2e28ed7153627081710aa75af (patch)
tree3341a8ce355ce90ac23cfb03041cfe69dc24d71b /configure.ac
parent3973147aa8e424bd2ab78304b54d914208d560d1 (diff)
downloadbluez-123e1ee1ce063af2e28ed7153627081710aa75af.tar.gz
profiles: Add initial code for mcp plugin
This adds initial code for mcp plugin which handles Media Control Profile and Generic Media Control Service for Client Role. The plugin exposes dbus methods for media control operations like play, pause which can be invoked using player menu in bluetoothctl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 79645e691..363a222a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -199,6 +199,10 @@ AC_ARG_ENABLE(bap, AS_HELP_STRING([--disable-bap],
[disable BAP profile]), [enable_bap=${enableval}])
AM_CONDITIONAL(BAP, test "${enable_bap}" != "no")
+AC_ARG_ENABLE(mcp, AS_HELP_STRING([--disable-mcp],
+ [disable MCP profile]), [enable_mcp=${enableval}])
+AM_CONDITIONAL(MCP, test "${enable_mcp}" != "no")
+
AC_ARG_ENABLE(vcp, AS_HELP_STRING([--disable-vcp],
[disable VCP profile]), [enable_vcp=${enableval}])
AM_CONDITIONAL(VCP, test "${enable_vcp}" != "no")