summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSonny Sasaka <sonnysasaka@chromium.org>2020-05-13 14:38:12 -0700
committerMarcel Holtmann <marcel@holtmann.org>2020-05-18 09:52:36 +0200
commit15e8fbfdf1f9cf0353075390984e6f693307a0eb (patch)
tree4f7dee43f344668cee43bb981b56e2e35e962b8b /configure.ac
parent2cd067b8b74c34a76ec08d2ccf3396fa9d24e838 (diff)
downloadbluez-15e8fbfdf1f9cf0353075390984e6f693307a0eb.tar.gz
build: Add an option to explicitly enable hid2hci
hid2hci is no longer a common use. This patch changes the default to not build and install hid2hci and provide a configure flag --enable-hid2hci to explicitly enable it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1433ace4a..e1c8fd9ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,7 +218,9 @@ if (test "${enable_udev}" != "no" && test -z "${path_udevdir}"); then
fi
AC_SUBST(UDEV_DIR, [${path_udevdir}])
-AM_CONDITIONAL(HID2HCI, test "${enable_tools}" != "no" &&
+AC_ARG_ENABLE(hid2hci, AC_HELP_STRING([--enable-hid2hci],
+ [enable hid2hci tool]), [enable_hid2hci=${enableval}])
+AM_CONDITIONAL(HID2HCI, test "${enable_hid2hci}" = "yes" &&
test "${enable_udev}" != "no")
AC_ARG_ENABLE(cups, AC_HELP_STRING([--disable-cups],