summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-03-24 11:15:43 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-04-01 14:57:37 +0300
commit25bce13507dfe9a1df2c10c4efd74190bba0eda5 (patch)
tree8bc63d2ee6eeb7d61e28105e9e44f16735c2221f /configure.ac
parentcc235a8d528b36cad2cf9fe6517d54711613331a (diff)
downloadbluez-25bce13507dfe9a1df2c10c4efd74190bba0eda5.tar.gz
build: Make old GATT plugins deprecated
This disables building plugins that are no longer supported by the core since the transition to gatt-db. In the future these plugins will have to be ported to use gatt-db or be removed if the profile can be implemented using the GATT D-Bus APIs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf4012687..1679a4767 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,6 +247,11 @@ AC_ARG_ENABLE(experimental, AC_HELP_STRING([--enable-experimental],
[enable_experimental=${enableval}])
AM_CONDITIONAL(EXPERIMENTAL, test "${enable_experimental}" = "yes")
+AC_ARG_ENABLE(deprecated, AC_HELP_STRING([--enable-deprecated],
+ [enable deprecated plugins (BLE services, ...)]),
+ [enable_deprecated=${enableval}])
+AM_CONDITIONAL(DEPRECATED, test "${enable_deprecated}" = "yes")
+
AC_ARG_ENABLE(sixaxis, AC_HELP_STRING([--enable-sixaxis],
[enable sixaxis plugin]), [enable_sixaxis=${enableval}])
AM_CONDITIONAL(SIXAXIS, test "${enable_sixaxis}" = "yes" &&