summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-11 16:17:18 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-17 14:15:42 +0200
commit26e38bbcef1b7ab53290ed3a113a4328700e7e80 (patch)
treedf3bf317c82ff4612d2ae1aa8e1a6ce1cb820a4c /configure.ac
parent64a08d1524a7d3832fd03f04ffd8fc7765877a15 (diff)
downloadbluez-26e38bbcef1b7ab53290ed3a113a4328700e7e80.tar.gz
build: Add option to enable NFC pairing
This adds --enable-nfc option dedicated to enabled neard plugin so it is no longer enabled with --enable-experimental since that enables other plugins that might not be relevant for the system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 530d512ee..e1aa20a8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,6 +140,10 @@ AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-test],
[enable test/example scripts]), [enable_test=${enableval}])
AM_CONDITIONAL(TEST, test "${enable_test}" = "yes")
+AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-nfc],
+ [enable NFC paring]), [enable_nfc=${enableval}])
+AM_CONDITIONAL(NFC, test "${enable_nfc}" = "yes")
+
AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")