summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRonan Pigott <rpigott@berkeley.edu>2019-08-16 23:34:52 -0700
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2019-09-06 10:58:05 +0300
commit3825bc7f25bea1f0b2198402247aceedad327743 (patch)
tree57a7a12b7e7c5c705c6a4c9dc1a0b13bd0a33cbd /configure.ac
parent760640a04e669939a4c2d69aa6ab7001f5208f2a (diff)
downloadbluez-3825bc7f25bea1f0b2198402247aceedad327743.tar.gz
build: install zsh completions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0afe1e6db..76612ff07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,18 @@ if (test -z "${path_dbussessionbusdir}"); then
fi
AC_SUBST(DBUS_SESSIONBUSDIR, [${path_dbussessionbusdir}])
+AC_ARG_WITH([zsh-completion-dir], AC_HELP_STRING([--with-zsh-completion-dir=DIR],
+ [path to install zsh completions]),
+ [path_zshcompletiondir=${withval}],
+ [path_zshcompletiondir="yes"])
+
+if (test "${path_zshcompletiondir}" = "yes"); then
+ path_zshcompletiondir="$datarootdir/zsh/site-functions"
+ AC_MSG_RESULT([${path_zshcompletiondir}])
+fi
+AC_SUBST(ZSH_COMPLETIONDIR, [${path_zshcompletiondir}])
+AM_CONDITIONAL(ZSH_COMPLETIONS, test "${path_zshcompletiondir}" != "no")
+
AC_ARG_ENABLE(backtrace, AC_HELP_STRING([--enable-backtrace],
[compile backtrace support]), [enable_backtrace=${enableval}])