summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2020-08-04 17:09:27 -0700
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2022-08-29 12:43:03 -0700
commit47ba235f5a6ff9173727311adefab45609fc2ad8 (patch)
tree61b72cc80df2575e68288ce279e896ff8c932861 /configure.ac
parentb798cec4ca623095c57fcba73148fb955db3b096 (diff)
downloadbluez-47ba235f5a6ff9173727311adefab45609fc2ad8.tar.gz
profiles: Add initial code for bap plugin
This adds initial code for bap plugin which handles Basic Audio Profile, Publish Audio Capabilities Service and Audio Stream Control Service.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 91fd19411..1f76915b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,6 +195,10 @@ AC_ARG_ENABLE(health, AS_HELP_STRING([--enable-health],
[enable health profiles]), [enable_health=${enableval}])
AM_CONDITIONAL(HEALTH, test "${enable_health}" = "yes")
+AC_ARG_ENABLE(bap, AS_HELP_STRING([--disable-bap],
+ [disable BAP profile]), [enable_bap=${enableval}])
+AM_CONDITIONAL(BAP, test "${enable_bap}" != "no")
+
AC_ARG_ENABLE(tools, AS_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")