summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2018-05-16 21:36:07 +0300
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2018-05-17 13:04:52 +0300
commit5852a75d797059080770af12d3b7ba7b68897268 (patch)
tree74c975e3e6e3e2704a55bbb80b9ca49184c327a9 /configure.ac
parente1129bcf881183a813d9b8fd7cb7ef9a1a46005a (diff)
downloadbluez-5852a75d797059080770af12d3b7ba7b68897268.tar.gz
build: Fix requiring ell
Make sure libshared-ell is only build if ell is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5132131f2..2daf1aaa4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -248,12 +248,13 @@ AC_ARG_ENABLE(btpclient, AC_HELP_STRING([--enable-btpclient],
[enable BTP client]), [enable_btpclient=${enableval}])
AM_CONDITIONAL(BTPCLIENT, test "${enable_btpclient}" = "yes")
-if (test "${enable_btpclient}" = "yes"); then
- PKG_CHECK_MODULES(ELL, ell >= 0.3, dummy=yes,
+if (test "${enable_btpclient}" = "yes" || test "${enable_mesh}" = "yes"); then
+ PKG_CHECK_MODULES(ELL, ell >= 0.3, enable_ell=yes,
AC_MSG_ERROR(ell library >= 0.3 is required))
AC_SUBST(ELL_CFLAGS)
AC_SUBST(ELL_LIBS)
fi
+AM_CONDITIONAL(ELL, test "${enable_ell}" = "yes")
AC_ARG_ENABLE(client, AC_HELP_STRING([--disable-client],
[disable command line client]), [enable_client=${enableval}])