summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2015-05-05 12:27:09 +0300
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2015-05-18 21:35:40 +0300
commit65f10c8537f794314c0055764d70d474d79cd558 (patch)
tree352311e0c467867f9823d96ae8c5bf7bd10286f4 /configure.ac
parent314cf642223e3bd2c317057ebfcdc36df6b22c4d (diff)
downloadbluez-65f10c8537f794314c0055764d70d474d79cd558.tar.gz
build: Check if dbus-run-session for unit tests
This checks if dbus-run-session is available and then add it to AM_TESTS_ENVIRONMENT so tests using D-Bus run in its own session.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1016ee4ee..d63265747 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,8 +34,10 @@ AC_PROG_LIBTOOL
if (test "$USE_MAINTAINER_MODE" = "yes"); then
AC_CHECK_PROG(enable_coverage, [lcov], [yes], [no])
+ AC_CHECK_PROG(enable_dbus_run_session, [dbus-run-session], [yes])
fi
AM_CONDITIONAL(COVERAGE, test "${enable_coverage}" = "yes")
+AM_CONDITIONAL(DBUS_RUN_SESSION, test "${enable_dbus_run_session}" = "yes")
MISC_FLAGS