summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Gix <brian.gix@intel.com>2019-04-01 11:45:18 -0700
committerBrian Gix <brian.gix@intel.com>2019-04-03 10:31:42 -0700
commit713f1931e6faed031af9facfa697c589b5640e6c (patch)
tree7d2f5eb8116087abf9fa99d3d6ebf2110eb56c09 /configure.ac
parent56d782116e6fb0bb283e8172063ca729ce2b402e (diff)
downloadbluez-713f1931e6faed031af9facfa697c589b5640e6c.tar.gz
build: Check if explicit_bzero is missing
This check gets around the redefinition of explicit_bzero in ELL In file included from ell/random.c:34:0: ell/missing.h:59:20: error: static declaration of ‘explicit_bzero’ follows non-static declaration static inline void explicit_bzero(void *s, size_t n) ^~~~~~~~~~~~~~ In file included from ./ell/util.h:26:0, from ell/private.h:26, from ell/random.c:33: /usr/include/string.h:435:13: note: previous declaration of ‘explicit_bzero’ was here extern void explicit_bzero (void *__s, size_t __n) __THROW __nonnull ((1)); ^~~~~~~~~~~~~~
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae64ddc0f..0afe1e6db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,8 @@ MISC_FLAGS
AC_ARG_ENABLE(threads, AC_HELP_STRING([--enable-threads],
[enable threading support]), [enable_threads=${enableval}])
+AC_CHECK_FUNCS(explicit_bzero)
+
AC_CHECK_FUNC(signalfd, dummy=yes,
AC_MSG_ERROR(signalfd support is required))