summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2014-12-15 10:28:54 -0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2014-12-16 10:02:26 -0200
commit7144164cdf6a1c8cda87c36a77efc1539e8349a7 (patch)
tree643a2fab96a30316bdd8c7253ab3e7b8bc72e6e6 /configure.ac
parent6f42c2c6f0543c7231229da7aef402657518f96b (diff)
downloadbluez-7144164cdf6a1c8cda87c36a77efc1539e8349a7.tar.gz
build: Fix enabling coverage
Since MISC_FLAGS now checks for enable_coverage to add --coverage flag the check for lcov needs happen before before it otherwise make coverage doesn't work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a70d55a5b..0acd73492 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,11 @@ m4_ifdef([AC_LIBTOOL_TAGS], [AC_LIBTOOL_TAGS([])])
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
+if (test "$USE_MAINTAINER_MODE" = "yes"); then
+ AC_CHECK_PROG(enable_coverage, [lcov], [yes], [no])
+fi
+AM_CONDITIONAL(COVERAGE, test "${enable_coverage}" = "yes")
+
MISC_FLAGS
AC_ARG_ENABLE(threads, AC_HELP_STRING([--enable-threads],
@@ -274,9 +279,4 @@ fi
AC_DEFINE_UNQUOTED(ANDROID_STORAGEDIR, "${storagedir}/android",
[Directory for the Android daemon storage files])
-if (test "$USE_MAINTAINER_MODE" = "yes"); then
- AC_CHECK_PROG(enable_coverage, [lcov], [yes], [no])
-fi
-AM_CONDITIONAL(COVERAGE, test "${enable_coverage}" = "yes")
-
AC_OUTPUT(Makefile src/bluetoothd.8 lib/bluez.pc)