summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2014-12-14 00:31:26 +0100
committerMarcel Holtmann <marcel@holtmann.org>2014-12-14 00:33:41 +0100
commit78cbdd40b2c4a10f7b6de53dc82663f2eaed523e (patch)
tree354ca36ee80611213b157f14c3abed09819f364c /configure.ac
parentce49d2b39b51ddb8bc9cb23762fc201b557175fb (diff)
downloadbluez-78cbdd40b2c4a10f7b6de53dc82663f2eaed523e.tar.gz
build: Fix detection of coverage support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 196e7849d..a70d55a5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -275,8 +275,8 @@ AC_DEFINE_UNQUOTED(ANDROID_STORAGEDIR, "${storagedir}/android",
[Directory for the Android daemon storage files])
if (test "$USE_MAINTAINER_MODE" = "yes"); then
- AC_CHECK_PROG([LCOV], [lcov], [yes], AC_MSG_ERROR(lcov is required))
+ AC_CHECK_PROG(enable_coverage, [lcov], [yes], [no])
fi
-AM_CONDITIONAL(COVERAGE, test "$LCOV" = "yes")
+AM_CONDITIONAL(COVERAGE, test "${enable_coverage}" = "yes")
AC_OUTPUT(Makefile src/bluetoothd.8 lib/bluez.pc)