summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSathish Narasimman <sathish.narasimman@intel.com>2022-09-19 13:37:21 +0530
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2022-09-19 15:31:19 -0700
commita96ede87c63f1c4a397240841e1f460fbbc288b3 (patch)
treeb7af932d74ceb78b43de9badefd165f095f77c2f /configure.ac
parentb8a113ecbabcae1c6192bdb9b9ab6f352056c5bf (diff)
downloadbluez-a96ede87c63f1c4a397240841e1f460fbbc288b3.tar.gz
profiles: Add initial code for vcp plugin
This adds initial code for vcp plugin which handles Volume Control Profile and Volume Control Service.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1f76915b4..79645e691 100644
--- a/configure.ac
+++ b/configure.ac
@@ -199,6 +199,10 @@ AC_ARG_ENABLE(bap, AS_HELP_STRING([--disable-bap],
[disable BAP profile]), [enable_bap=${enableval}])
AM_CONDITIONAL(BAP, test "${enable_bap}" != "no")
+AC_ARG_ENABLE(vcp, AS_HELP_STRING([--disable-vcp],
+ [disable VCP profile]), [enable_vcp=${enableval}])
+AM_CONDITIONAL(VCP, test "${enable_vcp}" != "no")
+
AC_ARG_ENABLE(tools, AS_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")