summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2021-11-23 13:32:12 -0800
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2021-11-23 13:32:12 -0800
commitaa699cb762a02ec7409940ddcfe65b788de8270d (patch)
tree6444215daec81c3c9253262aad11023f4b83d354 /configure.ac
parent270c8d07a07815188d4359b81e00db135ff3ff63 (diff)
downloadbluez-aa699cb762a02ec7409940ddcfe65b788de8270d.tar.gz
build: Check for linux/uinput.h and linux/uhid.h
This makes configure to check the presence of linux/uinput.h and linux/uhid.h kernel uapi headers since the code no longer contain copies of them and otherwise the code cannot be build without them: checking linux/uinput.h usability... yes checking linux/uinput.h presence... yes checking for linux/uinput.h... yes checking linux/uhid.h usability... yes checking linux/uhid.h presence... yes checking for linux/uhid.h... yes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0329095ee..2674e30d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,7 +63,7 @@ AC_CHECK_LIB(pthread, pthread_create, dummy=yes,
AC_CHECK_LIB(dl, dlopen, dummy=yes,
AC_MSG_ERROR(dynamic linking loader is required))
-AC_CHECK_HEADERS(linux/types.h linux/if_alg.h)
+AC_CHECK_HEADERS(linux/types.h linux/if_alg.h linux/uinput.h linux/uhid.h)
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.28, dummy=yes,
AC_MSG_ERROR(GLib >= 2.28 is required))