summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJuho Hamalainen <juho.hamalainen@jolla.com>2021-07-23 15:58:22 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2021-07-23 14:47:37 -0700
commitb1c73f4d4cca9ffbbe16e325be8975002de20d9f (patch)
treee9b6c0ba6f69e6009ff792a30dba2e654a7bf9b6 /configure.ac
parentbdeaad3fa02825e32f2fb52ba2fee0dece856f60 (diff)
downloadbluez-b1c73f4d4cca9ffbbe16e325be8975002de20d9f.tar.gz
configure.ac: specify phonebook plugin at build time
Various phonebook plugins are available, by default phonebook-dummy is always built. Allow to specify which plugin to use at build time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index be32782a6..113ab0e0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -416,4 +416,12 @@ fi
AC_DEFINE_UNQUOTED(ANDROID_STORAGEDIR, "${storagedir}/android",
[Directory for the Android daemon storage files])
+AC_ARG_WITH([phonebook], AC_HELP_STRING([--with-phonebook=PLUGIN],
+ [obexd phonebook plugin (default=dummy)]),
+ [plugin_phonebook=${withval}])
+if (test -z "${plugin_phonebook}"); then
+ plugin_phonebook=dummy
+fi
+AC_SUBST(PLUGIN_PHONEBOOK, [${plugin_phonebook}])
+
AC_OUTPUT(Makefile src/bluetoothd.rst lib/bluez.pc mesh/bluetooth-meshd.rst)