summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTedd Ho-Jeong An <tedd.an@intel.com>2021-05-11 13:08:42 -0700
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2021-05-11 15:15:24 -0700
commitdb40060a8d59cd7d2ff940fb0f7e1d6234c88171 (patch)
tree4f5aaf93cec9c58f78d7028eb2579afdd5031bed /configure.ac
parentfa57cb68e13ea4a6cff5532830008d44254e7e83 (diff)
downloadbluez-db40060a8d59cd7d2ff940fb0f7e1d6234c88171.tar.gz
config: Show error if rst2man not found when manpages are enabled
This patch adds a check if the conversion tool is installed when the manpages is enabled, and show error if it is not installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f445589b0..2b044f8e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,6 +328,9 @@ AC_ARG_ENABLE(manpages, AC_HELP_STRING([--enable-manpages],
[enable_manpages=${enableval}])
if (test "${enable_manpages}" != "no"); then
AC_CHECK_PROGS(RST2MAN, [rst2man rst2man.py], "no")
+ if (test "${RST2MAN}" = "no" ); then
+ AC_MSG_ERROR([rst2man is required])
+ fi
fi
AM_CONDITIONAL(MANPAGES, test "${enable_manpages}" = "yes")
AM_CONDITIONAL(RUN_RST2MAN, test "${enable_manpages}" = "yes" && test "${RST2MAN}" != "no")