summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2017-01-04 15:24:45 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2017-01-17 11:27:26 +0200
commitdf43b3dad829e8b7f79fd15c20d997f50e745ae7 (patch)
treefede3685caf01b71da6f6fa5598b659012f2dd74 /configure.ac
parent301904d649db6df8ae4735d7a90109993d9a4523 (diff)
downloadbluez-df43b3dad829e8b7f79fd15c20d997f50e745ae7.tar.gz
build: Add testing config option
This adds --enable-testing that can be used to enable emulator and tester which are no longer experimental but also are not meant for production.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb8deab85..91b49555b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -285,6 +285,11 @@ AC_ARG_ENABLE(manpages, AC_HELP_STRING([--enable-manpages],
[enable_manpages=${enableval}])
AM_CONDITIONAL(MANPAGES, test "${enable_manpages}" = "yes")
+AC_ARG_ENABLE(testing, AC_HELP_STRING([--enable-testing],
+ [enable testing tools]),
+ [enable_testing=${enableval}])
+AM_CONDITIONAL(TESTING, test "${enable_testing}" = "yes")
+
AC_ARG_ENABLE(experimental, AC_HELP_STRING([--enable-experimental],
[enable experimental tools]),
[enable_experimental=${enableval}])