summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSzymon Janc <szymon.janc@codecoup.pl>2017-12-07 12:43:44 +0100
committerSzymon Janc <szymon.janc@codecoup.pl>2017-12-14 10:08:32 +0100
commitf68235b2c03235695837abfb6d7ceebacbf14dd9 (patch)
tree19c44684a87b4a47b47347407b789e04bf4b73b7 /configure.ac
parentb8cd86c3e2be9ae8f3294e4090179611ff69ba9c (diff)
downloadbluez-f68235b2c03235695837abfb6d7ceebacbf14dd9.tar.gz
tools/btpclient: Add initial code
This adds initial code for BTP client tool that allows for automated (binary protocol ) control of BlueZ stack. Currently this tool depends only on Embedded Linux Library and requires master branch of ELL. When 0.3 is released dependencies will be bumped. Initial code allows to connect D-Bus client, discover objects and keep proxies for it. It also implements basics for BTP core service.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 964101412..fcba28543 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,6 +244,17 @@ if (test "${enable_obex}" != "no"); then
fi
AM_CONDITIONAL(OBEX, test "${enable_obex}" != "no")
+AC_ARG_ENABLE(btpclient, AC_HELP_STRING([--enable-btpclient],
+ [enable BTP client]), [enable_btpclient=${enableval}])
+AM_CONDITIONAL(BTPCLIENT, test "${enable_btpclient}" = "yes")
+
+if (test "${enable_btpclient}" = "yes"); then
+ PKG_CHECK_MODULES(ELL, ell >= 0.2, dummy=yes,
+ AC_MSG_ERROR(ell library >= 0.2 is required))
+ AC_SUBST(ELL_CFLAGS)
+ AC_SUBST(ELL_LIBS)
+fi
+
AC_ARG_ENABLE(client, AC_HELP_STRING([--disable-client],
[disable command line client]), [enable_client=${enableval}])
AM_CONDITIONAL(CLIENT, test "${enable_client}" != "no")