summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9f0faf57..515cdf146 100644
--- a/configure.ac
+++ b/configure.ac
@@ -289,6 +289,11 @@ if (test "${enable_external_ell}" = "yes"); then
AC_SUBST(ELL_CFLAGS)
AC_SUBST(ELL_LIBS)
fi
+if (test "${enable_external_ell}" != "yes"); then
+ AC_CHECK_FILE(${srcdir}/ell/ell.h, dummy=yes,
+ AC_CHECK_FILE(${srcdir}/../ell/ell/ell.h, dummy=yes,
+ AC_MSG_ERROR(ELL source is required or use --enable-external-ell)))
+fi
AM_CONDITIONAL(EXTERNAL_ELL, test "${enable_external_ell}" = "yes" ||
(test "${enable_btpclient}" != "yes" &&
test "${enable_mesh}" != "yes"))