summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <doug.gregor@gmail.com>2009-05-06 21:12:42 +0000
committerDouglas Gregor <doug.gregor@gmail.com>2009-05-06 21:12:42 +0000
commit0551656d5b4f55597d3040b4ad6c9b8dda78dd20 (patch)
treeb4ee6254349c86d4dc6f74a6efcff32ba7d0ba79 /CMakeLists.txt
parent866a53ac5ebca57e8ea8514f316c670d14c88f3e (diff)
downloadboost-0551656d5b4f55597d3040b4ad6c9b8dda78dd20.tar.gz
Merge CMake fixes from the trunk
[SVN r52811]
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92d4b2388b..8d8ace8bed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -234,11 +234,17 @@ if(WIN32 AND NOT UNIX)
endif(WIN32 AND NOT UNIX)
include(CPack)
-if(COMMAND cpack_configure_downloads)
- cpack_configure_downloads(
- "http://www.osl.iu.edu/~dgregor/Boost-CMake/${BOOST_VERSION}/"
- ALL ADD_REMOVE)
+option(BOOST_INSTALLER_ON_THE_FLY
+ "Whether to build installers that download components on-the-fly" OFF)
+
+if (BOOST_INSTALLER_ON_THE_FLY)
+ if(COMMAND cpack_configure_downloads)
+ cpack_configure_downloads(
+ "http://www.osl.iu.edu/~dgregor/Boost-CMake/${BOOST_VERSION}/"
+ ALL ADD_REMOVE)
+ endif()
endif()
+
##########################################################################
##########################################################################