summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTroy D. Straszheim <troy@resophonic.com>2009-02-01 21:02:21 +0000
committerTroy D. Straszheim <troy@resophonic.com>2009-02-01 21:02:21 +0000
commit2388537278ac743b93ea79f89bd274ad5087c6aa (patch)
treeec8c2858551f3f58f5efe097ad247d86efb23e4e /CMakeLists.txt
parent23f2e63e20bd321192ed40479878f6e94881ccac (diff)
downloadboost-2388537278ac743b93ea79f89bd274ad5087c6aa.tar.gz
Be clear that this isn't Boost.Build and only boost build is
officially supported. [SVN r50957]
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0aecfea0f..92d4b2388b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,9 +34,13 @@ project(Boost)
##########################################################################
if (NOT CMAKE_IS_EXPERIMENTAL)
message(STATUS "##########################################################################")
-message(STATUS " This cmake-based build system is currently under development. The ")
-message(STATUS " bjam-based system is the 'standard' way to build boost. To try ")
-message(STATUS " try out the cmake build, invoke CMake with the argument")
+message(STATUS "")
+message(STATUS " Only Boost.Build is officially supported.")
+message(STATUS "")
+message(STATUS " This is not Boost.Build.")
+message(STATUS "")
+message(STATUS " This is an alternate, cmake-based build system that is currently under development.")
+message(STATUS " To try it out, invoke CMake with the argument")
message(STATUS " -DCMAKE_IS_EXPERIMENTAL=YES_I_KNOW")
message(STATUS " Or use the gui to set the variable CMAKE_IS_EXPERIMENTAL to some value.")
message(STATUS " This will only be necessary the first time.")
@@ -47,6 +51,9 @@ message(STATUS "")
message(STATUS " Subscribe to the mailing list:")
message(STATUS " http://lists.boost.org/mailman/listinfo.cgi/boost-cmake")
message(STATUS "")
+message(STATUS " NOTE: Please ask questions about this build system on the boost-cmake list,")
+message(STATUS " not on other boost lists.")
+message(STATUS "")
message(STATUS " And/or check the archives:")
message(STATUS " http://news.gmane.org/gmane.comp.lib.boost.cmake")
message(STATUS "")