summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Dimov <pdimov@gmail.com>2019-12-15 20:08:18 +0200
committerPeter Dimov <pdimov@gmail.com>2019-12-18 04:22:40 +0200
commit68cc708fcb4015fd0e03e60a66cbb962f1d14a1c (patch)
treeb402b56027d6a97172e38c1a7ffb4d9888704f6c /CMakeLists.txt
parentee1a68fa311d3256751b14281b3f7b5cbf9cde88 (diff)
downloadboost-68cc708fcb4015fd0e03e60a66cbb962f1d14a1c.tar.gz
Add CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000000..f903a132f5
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Copyright 2019 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5...3.16)
+
+project(Boost VERSION 1.73.0 LANGUAGES CXX)
+
+set(BOOST_SUPERPROJECT_VERSION ${PROJECT_VERSION})
+set(BOOST_SUPERPROJECT_SOURCE_DIR ${PROJECT_SOURCE_DIR})
+
+list(APPEND CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/tools/cmake/include)
+
+include(BoostRoot)