summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <doug.gregor@gmail.com>2009-05-15 01:32:19 +0000
committerDouglas Gregor <doug.gregor@gmail.com>2009-05-15 01:32:19 +0000
commit742f0fbbeadca41926893ec7deab98a67404687e (patch)
treecdfda76cabf6d2d02783c4d6ac2c983b59903a06 /CMakeLists.txt
parentc1af8bba96a48dfee61a00b0deb4928b52f89a16 (diff)
downloadboost-742f0fbbeadca41926893ec7deab98a67404687e.tar.gz
Make sure that CMake reconfigures when boost/version.hpp changes
[SVN r53009]
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 684c799833..e4ddc93ba9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,10 @@ else()
message(FATAL_ERROR
"Unable to parse Boost version from ${CMAKE_CURRENT_SOURCE_DIR}/boost/version.hpp")
endif()
+
+# Make sure that we reconfigure when boost/version.hpp changes.
+configure_file(boost/version.hpp
+ ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/version.stamp)
##########################################################################
# Put the libaries and binaries that get built into directories at the