summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcel Hellkamp <marc@gsites.de>2009-07-07 01:27:31 +0200
committerMarcel Hellkamp <marc@gsites.de>2009-07-07 01:27:31 +0200
commit587ed466e2d4a8962a108c01354e8fe036bc127f (patch)
tree16b6c40ca094b645eb84cdbacf99b1238456944a /setup.py
parent850c2ab33c2f473f2959c7b96202001b416ea6f3 (diff)
downloadbottle-587ed466e2d4a8962a108c01354e8fe036bc127f.tar.gz
Added setup script
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..5e9cbc0
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,28 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+import bottle
+
+setup(name='Bottle',
+ version='%d.%d.%d' % bottle.__version__,
+ description='Bottle Web Framework',
+ long_description=open('README.md').read(),
+ author='Marcel Hellkamp',
+ author_email='marc@gsites.de',
+ url='http://github.com/defnull/bottle',
+ py_modules=['bottle'],
+ license='MIT',
+ classifiers=['Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries',
+ 'Topic :: Internet :: WWW/HTTP :: HTTP Servers',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Application',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Server',
+ 'Topic :: Software Development :: Libraries :: Application Frameworks']
+ )
+
+
+