summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index b0f5685..c701850 100755
--- a/setup.py
+++ b/setup.py
@@ -3,8 +3,8 @@
import sys
from setuptools import setup
-if sys.version_info < (2, 7):
- raise NotImplementedError("Sorry, you need at least Python 2.7 or Python 3.4+ to use bottle.")
+if sys.version_info < (3, 5):
+ raise NotImplementedError("Sorry, you need at least Python 3.5 to use bottle.")
import bottle
@@ -31,9 +31,7 @@ setup(name='bottle',
'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
'Topic :: Internet :: WWW/HTTP :: WSGI :: Server',
'Topic :: Software Development :: Libraries :: Application Frameworks',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',