summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2016-03-15 09:18:36 -0400
committerColin Walters (automation) <walters+githubbot@verbum.org>2016-03-15 15:34:28 +0000
commite06ff186ce96f1aee1cf260602e59f7e5a6c3b19 (patch)
tree37778054e6a2a94ff7c11759ce8a819ffc58157d /Makefile.am
parentbf3ae2166fbe20831bc42e4778fa2ff6cd32bb78 (diff)
downloadbubblewrap-e06ff186ce96f1aee1cf260602e59f7e5a6c3b19.tar.gz
tests: Add a stub test framework
Imported a little bit of code from OSTree's shell `libtest.sh`. I'm mostly doing this to test Travis and Homu, but hey, we get a little bit of coverage. Pull request: #21 Approved by: alexlarsson
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8427f99..8fc2ae9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,3 +13,6 @@ test-setcaps: bwrap
sudo setcap "cap_sys_admin+ep cap_sys_chroot+ep" bwrap
include Makefile-docs.am
+
+TESTS = tests/test-basic.sh
+TESTS_ENVIRONMENT = PATH=$$(cd $(top_builddir) && pwd):$${PATH}