summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2021-06-11 10:14:07 +0100
committerSimon McVittie <smcv@collabora.com>2021-06-22 17:52:53 +0100
commiteb48ee8347ee07be15f5ed08089a9ddfd6a906fb (patch)
tree7734546633a69dc20d181210e8a9d9cc50b2e523 /configure.ac
parent6714024bedb3326f086c09c3a4608f744970072b (diff)
downloadbubblewrap-eb48ee8347ee07be15f5ed08089a9ddfd6a906fb.tar.gz
utils: Remove security_context_t casts for libselinux >= 2.3
security_context_t has always been a typedef for char * and used more or less interchangeably with char *, but the use of a typedef turned out to be bad for const-correctness. The function signatures were changed to take const char * in libselinux 2.3, in 2014[1] and the typedef was formally deprecated in 2020[2]. On very old OSs like Ubuntu 14.04, reinstate the casts to suppress warnings from -Wdiscarded-qualifiers. [1] https://github.com/SELinuxProject/selinux/commit/9eb9c9327563 [2] https://github.com/SELinuxProject/selinux/commit/7a124ca27581 Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dd6f9e3..6167ea4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,9 @@ if test "x$enable_selinux" != "xno"; then
if test "x$have_selinux" = xno -a "x$enable_selinux" = xyes; then
AC_MSG_ERROR([*** SELinux support requested but libraries not found])
fi
+ PKG_CHECK_MODULES([SELINUX_2_3], [libselinux >= 2.3],
+ [AC_DEFINE(HAVE_SELINUX_2_3, 1, [Define if SELinux is version >= 2.3])],
+ [:])
fi
AM_CONDITIONAL(HAVE_SELINUX, [test "$have_selinux" = "yes"])