summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-02-19 14:47:12 +0000
committerSimon McVittie <smcv@collabora.com>2022-02-20 11:41:24 +0000
commit12c920b492d8c1536b26593b0bcbc984ea97419f (patch)
tree64ed85bdb0c7a48dca950653e9fd06ccfc50a085 /meson.build
parent5750517e1c47d70e47ff9170586911ab99554267 (diff)
downloadbubblewrap-12c920b492d8c1536b26593b0bcbc984ea97419f.tar.gz
meson: Run the Python test script with Python, not bash
The python build option can be used to swap to a different interpreter, for environments like the Steam Runtime where the python3 executable in the PATH is extremely old but there is a better interpreter available. This is treated as non-optional, because Meson is written in Python, so the situation where there is no Python interpreter at build-time shouldn't arise. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 01fcc19..598c42e 100644
--- a/meson.build
+++ b/meson.build
@@ -64,6 +64,12 @@ endif
bash = find_program('bash', required : false)
+if get_option('python') == ''
+ python = find_program('python3')
+else
+ python = find_program(get_option('python'))
+endif
+
libcap_dep = dependency('libcap', required : true)
selinux_dep = dependency(