summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-02-19 14:47:12 +0000
committerSimon McVittie <smcv@collabora.com>2022-02-20 11:41:24 +0000
commit12c920b492d8c1536b26593b0bcbc984ea97419f (patch)
tree64ed85bdb0c7a48dca950653e9fd06ccfc50a085 /tests/meson.build
parent5750517e1c47d70e47ff9170586911ab99554267 (diff)
downloadbubblewrap-12c920b492d8c1536b26593b0bcbc984ea97419f.tar.gz
meson: Run the Python test script with Python, not bash
The python build option can be used to swap to a different interpreter, for environments like the Steam Runtime where the python3 executable in the PATH is extremely old but there is a better interpreter available. This is treated as non-optional, because Meson is written in Python, so the situation where there is no Python interpreter at build-time shouldn't arise. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 12b7997..aabd1e0 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -46,10 +46,16 @@ foreach pair : test_programs
endforeach
foreach test_script : test_scripts
+ if test_script.endswith('.py')
+ interpreter = python
+ else
+ interpreter = bash
+ endif
+
if meson.version().version_compare('>=0.50.0')
test(
test_script,
- bash,
+ interpreter,
args : [test_script],
env : test_env,
protocol : 'tap',
@@ -57,7 +63,7 @@ foreach test_script : test_scripts
else
test(
test_script,
- bash,
+ interpreter,
args : [test_script],
env : test_env,
)