summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 159ab2b..85513f3 100644
--- a/meson.build
+++ b/meson.build
@@ -10,6 +10,7 @@ project(
cc = meson.get_compiler('c')
add_project_arguments('-D_GNU_SOURCE', language : 'c')
+common_include_directories = include_directories('.')
# Keep this in sync with ostree, except remove -Wall (part of Meson
# warning_level 2) and -Werror=declaration-after-statement
@@ -61,9 +62,14 @@ if (
], language : 'c')
endif
-sh = find_program('sh', required : true)
bash = find_program('bash', required : false)
+if get_option('python') == ''
+ python = find_program('python3')
+else
+ python = find_program(get_option('python'))
+endif
+
libcap_dep = dependency('libcap', required : true)
selinux_dep = dependency(
@@ -145,3 +151,5 @@ endif
if not meson.is_subproject()
subdir('completions')
endif
+
+subdir('tests')