summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 7 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index c4ba441..7d51a85 100644
--- a/meson.build
+++ b/meson.build
@@ -101,12 +101,14 @@ configure_file(
configuration : cdata,
)
-if meson.is_subproject()
- bwrapdir = get_option('libexecdir')
+if meson.is_subproject() and get_option('program_prefix') == ''
+ error('program_prefix option must be set when bwrap is a subproject')
+endif
- if get_option('program_prefix') == ''
- error('program_prefix option must be set when bwrap is a subproject')
- endif
+if get_option('bwrapdir') != ''
+ bwrapdir = get_option('bwrapdir')
+elif meson.is_subproject()
+ bwrapdir = get_option('libexecdir')
else
bwrapdir = get_option('bindir')
endif