summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorJames Ennis <james.ennis@codethink.com>2018-03-08 18:04:14 +0000
committerJames Ennis <james.ennis@codethink.com>2018-03-14 14:10:26 +0000
commit76818202bbfe31703c79aa0e58416ee1b0f397c2 (patch)
tree6221824a3a82c2fbfd125e532cbd06ee5141523c /setup.cfg
parent92b04688a41b7306963789519189344950f892b6 (diff)
downloadbuildstream-76818202bbfe31703c79aa0e58416ee1b0f397c2.tar.gz
Add pylint to setup.cfg and setup.py
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.cfg b/setup.cfg
index 146f15347..4540ae9f3 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -2,8 +2,8 @@
test=pytest
[tool:pytest]
-addopts = --verbose --basetemp ./tmp --pep8 --cov=buildstream --cov-config .coveragerc
-norecursedirs = integration-cache tmp __pycache__
+addopts = --verbose --basetemp ./tmp --pylint-rcfile=.pylintrc --cov=buildstream --cov-config .coveragerc
+norecursedirs = integration-cache tmp __pycache__ .eggs
python_files = tests/*/*.py
pep8maxlinelength = 119
pep8ignore =