summaryrefslogtreecommitdiff
path: root/doc/examples/out-of-source-build/files/OutOfSourceProject/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/examples/out-of-source-build/files/OutOfSourceProject/CMakeLists.txt')
-rw-r--r--doc/examples/out-of-source-build/files/OutOfSourceProject/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/doc/examples/out-of-source-build/files/OutOfSourceProject/CMakeLists.txt b/doc/examples/out-of-source-build/files/OutOfSourceProject/CMakeLists.txt
new file mode 100644
index 000000000..287c78371
--- /dev/null
+++ b/doc/examples/out-of-source-build/files/OutOfSourceProject/CMakeLists.txt
@@ -0,0 +1,14 @@
+
+# Set the minimum version of CMake that can be used
+# To find the cmake version run
+# $ cmake --version
+cmake_minimum_required(VERSION 2.8)
+
+# Set the project name
+project (hello_main C)
+
+# Set something so that we can see if main.c was compiled from this cmake
+# projcet
+set(CMAKE_C_FLAGS "-DFULL_PROJECT")
+
+add_subdirectory(main)