summaryrefslogtreecommitdiff
path: root/doc/examples/out-of-source-build/files/OutOfSourceProject/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/examples/out-of-source-build/files/OutOfSourceProject/main/CMakeLists.txt')
-rw-r--r--doc/examples/out-of-source-build/files/OutOfSourceProject/main/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/doc/examples/out-of-source-build/files/OutOfSourceProject/main/CMakeLists.txt b/doc/examples/out-of-source-build/files/OutOfSourceProject/main/CMakeLists.txt
new file mode 100644
index 000000000..417693296
--- /dev/null
+++ b/doc/examples/out-of-source-build/files/OutOfSourceProject/main/CMakeLists.txt
@@ -0,0 +1,14 @@
+
+# Set the minimum version of CMake that can be used
+# To find the cmake version run
+# $ cmake --version
+cmake_minimum_required(VERSION 2.8)
+
+# Set the project name
+project (hello_buildstreams C)
+
+# Add an executable
+add_executable(hello_buildstream main.c)
+
+
+install(TARGETS hello_buildstream DESTINATION /bin)