summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2010-08-07 20:05:42 +0200
committerBenjamin Otte <otte@redhat.com>2010-08-07 20:19:27 +0200
commit661f4859cdbc0394ed0a9db34ced0f4e2bbe78ff (patch)
tree1b5d218bc7ca1802540e1abcd606d6ccb4e802fd /configure.ac
parentfc4e8f036326da1839ec5320eba60823e7efc2db (diff)
downloadcairo-661f4859cdbc0394ed0a9db34ced0f4e2bbe78ff.tar.gz
Add cairo-gobject library
This library is supposed to contain GType declarations for Cairo types. It is also meant to support gobject-introspection binding creation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e75f0db19..3c3084144 100644
--- a/configure.ac
+++ b/configure.ac
@@ -652,6 +652,15 @@ AC_SUBST(real_pthread_LIBS)
dnl ===========================================================================
+dnl Build gobject integration library
+
+CAIRO_ENABLE_FUNCTIONS(gobject, gobject, yes, [
+ gobject_REQUIRES="gobject-2.0"
+ PKG_CHECK_MODULES(gobject, $gobject_REQUIRES, , [AC_MSG_RESULT(no)
+ use_gobject="no (requires $gobject_REQUIRES http://download.gnome.org/pub/GNOME/sources/glib/)"])
+])
+
+dnl ===========================================================================
dnl Default to quick testing during development, but force a full test before
dnl release
@@ -791,6 +800,7 @@ test/pdiff/Makefile
perf/Makefile
util/Makefile
util/cairo-fdr/Makefile
+util/cairo-gobject/Makefile
util/cairo-script/Makefile
util/cairo-script/examples/Makefile
util/cairo-sphinx/Makefile