summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDave Beckett <Dave.Beckett@bristol.ac.uk>2003-11-08 10:28:04 +0000
committerDave Beckett <Dave.Beckett@bristol.ac.uk>2003-11-08 10:28:04 +0000
commit9aa2d445b7de7a8ebdf98c8bb6a13f985ee11b86 (patch)
treec4c6c0c053b23ee651641fb882367cf56a46217c /configure.in
parentf0d9ab5b2963bf2a35f09944de0d7084c4cfaa71 (diff)
downloadcairo-9aa2d445b7de7a8ebdf98c8bb6a13f985ee11b86.tar.gz
Use freetype-config to get the freetype2 compiling and linking flags rather than use pkg-config which requires a quite new freetype2 to get freetype2.pc
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in42
1 files changed, 41 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d2b8680c7..a93fdce75 100644
--- a/configure.in
+++ b/configure.in
@@ -40,7 +40,47 @@ AC_PATH_XTRA
dnl ===========================================================================
-PKG_CHECK_MODULES(CAIRO, fontconfig freetype2 slim >= 0.2.0 libic >= 0.1.3 xrender >= 0.6)
+PKG_CHECK_MODULES(CAIRO, fontconfig slim >= 0.2.0 libic >= 0.1.3 xrender >= 0.6)
+
+# Test for freetype2 separate from pkg-config since at least up to
+# 2003-06-07, there was no freetype2.pc in the release.
+#
+# Freetype versions come in three forms:
+# release (such as 2.1.5)
+# libtool (such as 9.4.3)
+# platform-specific/soname (such as 6.3.4)
+# and they recommend you never use the platform-specific version
+# (see docs/VERSION.DLL in freetype2 sources)
+#
+# Set these as appropriate:
+
+# release number - for information only
+FREETYPE_MIN_RELEASE=2.1.0
+# platform-specific version - this is what is checked
+FREETYPE_MIN_VERSION=8.0.2
+
+if test -z "$FREETYPE_CONFIG"; then
+ AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
+fi
+if test "$FREETYPE_CONFIG" = "no" ; then
+ AC_MSG_ERROR(No freetype-config script found in path or FREETYPE_CONFIG)
+fi
+
+AC_MSG_CHECKING(freetype2 libtool version)
+
+FREETYPE_VERSION=`$FREETYPE_CONFIG --version`
+
+VERSION_DEC=`echo $FREETYPE_VERSION | awk -F. '{printf("%d\n", 10000*$1 + 100*$2 + $3)};'`
+MIN_VERSION_DEC=`echo $FREETYPE_MIN_VERSION | awk -F. '{printf("%d\n", 10000*$1 + 100*$2 + $3)};'`
+if test $VERSION_DEC -lt $MIN_VERSION_DEC; then
+ AC_MSG_ERROR($FREETYPE_VERSION - version $FREETYPE_MIN_VERSION from release $FREETYPE_MIN_RELEASE required)
+fi
+AC_MSG_RESULT($FREETYPE_VERSION - OK)
+
+CAIRO_CFLAGS="CAIRO_CFLAGS `$FREETYPE_CONFIG --cflags`"
+CAIRO_LIBS="$CAIRO_LIBS `$FREETYPE_CONFIG --libs`"
+
+
AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(CAIRO_LIBS)