summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-18 11:12:42 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-04-27 16:59:35 +0100
commit0f39b795754681120c06f760362554d7e2b5c753 (patch)
treefafb0c585ac7d809e608e828d98b56c6ac89b6e0 /meson.build
parent966b4a4e5fb487a2400fcb2a62b51a7e93913489 (diff)
downloadcairo-0f39b795754681120c06f760362554d7e2b5c753.tar.gz
Define _GNU_SOURCE in order to use memmem
The memmem() function is a GNU extension, which means we need to define _GNU_SOURCE in order to avoid a compiler warning about a missing declaration.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1e14b3286..d4f759224 100644
--- a/meson.build
+++ b/meson.build
@@ -43,6 +43,8 @@ if cc.get_id() == 'msvc'
language : 'c')
endif
+add_project_arguments('-D_GNU_SOURCE', language: 'c')
+
# Make sure source directory hasn't been configured with autotools
if meson.version().version_compare('>= 0.53')
fs = import('fs')