summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdrian Johnson <ajohnson@redneon.com>2022-06-15 07:05:52 +0930
committerAdrian Johnson <ajohnson@redneon.com>2022-12-28 13:22:00 +1030
commit252ff60f1ee62c5b36d650b91ac2536d03656bea (patch)
tree8889fea7e5acbfdb6c98c5fcb81ba0cbef258d82 /meson.build
parent1bd5751324866a2bfbb084fcb7d5462d983a878e (diff)
downloadcairo-252ff60f1ee62c5b36d650b91ac2536d03656bea.tar.gz
SVG font test using cairo logo
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 831527c43..02f74856c 100644
--- a/meson.build
+++ b/meson.build
@@ -302,6 +302,8 @@ if fontconfig_dep.found()
}]
endif
+ttx = find_program('ttx', required: false)
+
freetype_dep = dependency('freetype2',
required: get_option('freetype'),
version: freetype_required_version,
@@ -339,6 +341,9 @@ if freetype_dep.found()
endif
if cc.has_type('FT_SVG_Document', dependencies: freetype_dep, prefix: '#include <freetype/otsvg.h>')
conf.set('HAVE_FT_SVG_DOCUMENT', 1)
+ if ttx.found()
+ conf.set('CAIRO_CAN_TEST_TTX_FONT', 1)
+ endif
endif
check_funcs += ft_check_funcs
deps += [freetype_dep]