summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdrian Johnson <ajohnson@redneon.com>2022-05-06 21:14:13 +0930
committerAdrian Johnson <ajohnson@redneon.com>2022-12-28 13:22:00 +1030
commit31700fed4f4eb2efb1b445c27b4016ea85bb14f3 (patch)
tree23d102d82f3b0d413665ab68cbe5701d0f9673ed /meson.build
parent392423aba38c0934235f17a40130d2e66e4490b0 (diff)
downloadcairo-31700fed4f4eb2efb1b445c27b4016ea85bb14f3.tar.gz
Support SVG fonts in FT backend
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 756cfcd6c..831527c43 100644
--- a/meson.build
+++ b/meson.build
@@ -337,6 +337,9 @@ if freetype_dep.found()
if not cc.links(files('meson-cc-tests/ft_has_color.c'), dependencies: freetype_dep, name: 'FT has color')
conf.set('FT_HAS_COLOR', '(0)')
endif
+ if cc.has_type('FT_SVG_Document', dependencies: freetype_dep, prefix: '#include <freetype/otsvg.h>')
+ conf.set('HAVE_FT_SVG_DOCUMENT', 1)
+ endif
check_funcs += ft_check_funcs
deps += [freetype_dep]
endif