summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorUli Schlachter <psychon@znc.in>2021-03-01 14:06:02 +0100
committerUli Schlachter <psychon@znc.in>2021-03-01 14:06:02 +0100
commit55a5951742ca5a1e90d1e53aeb46ff346e33b76f (patch)
treefe22c941fa49cc4d6ca0a2279dc1c3412b0cba25 /meson.build
parent553c19df16bbc42e8e3dab04bd5f335600b717f4 (diff)
downloadcairo-55a5951742ca5a1e90d1e53aeb46ff346e33b76f.tar.gz
meson: Move libspectre to test_deps
libspectre is only used for ps tests. Adding it to "deps" needlessly makes it show up in cairo.pc's Requires.private. Fixes: https://gitlab.freedesktop.org/cairo/cairo/-/issues/425 Signed-off-by: Uli Schlachter <psychon@znc.in>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b1759b5f3..a20e4b1b0 100644
--- a/meson.build
+++ b/meson.build
@@ -696,7 +696,7 @@ if feature_conf.get('CAIRO_HAS_PS_SURFACE', 0) == 1
if libspectre_dep.found()
conf.set('CAIRO_HAS_SPECTRE', 1)
- deps += [libspectre_dep]
+ test_deps += [libspectre_dep]
endif
endif