summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJohn Ralls <jralls@ceridwen.us>2022-04-07 16:51:16 -0700
committerJohn Ralls <jralls@ceridwen.us>2022-04-24 13:08:48 -0700
commit77a8d0f9e4f730e90af6367b8569de62cc0f3c9e (patch)
tree2141c07690c51039e3039243c223a9fa99f5ff81 /meson.build
parent0048f0f8035549f024a6a8571afba84742cb3dac (diff)
downloadcairo-77a8d0f9e4f730e90af6367b8569de62cc0f3c9e.tar.gz
[quartz] Require at least Mac OS X 10.7 Lion
Allows removal of most conditional compilation and dlsym lookups.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 12 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 8c07f02e9..aa6506332 100644
--- a/meson.build
+++ b/meson.build
@@ -455,7 +455,6 @@ if host_machine.system() == 'darwin' and not get_option('quartz').disabled()
deps += [quartz_deps]
feature_conf.set('CAIRO_HAS_QUARTZ_SURFACE', 1)
- feature_conf.set('CAIRO_HAS_QUARTZ_FONT', 1)
feature_conf.set('CAIRO_HAS_QUARTZ_IMAGE_SURFACE', 1)
built_features += [
@@ -468,13 +467,18 @@ if host_machine.system() == 'darwin' and not get_option('quartz').disabled()
'name': 'cairo-quartz-image',
'description': 'Quartz Image surface backend',
'deps': quartz_deps,
- },
- {
- 'name': 'cairo-quartz-font',
- 'description': 'Quartz font backend',
- 'deps': quartz_deps,
- },
- ]
+ }]
+ compiler = meson.get_compiler('c')
+ if compiler.has_function('CTFontDrawGlyphs', prefix: '#include <ApplicationServices/ApplicationServices.h>',
+ dependencies: quartz_deps)
+ built_features += [
+ {
+ 'name': 'cairo-quartz-font',
+ 'description': 'Quartz font backend',
+ 'deps': quartz_deps,
+ }]
+ feature_conf.set('CAIRO_HAS_QUARTZ_FONT', 1)
+ endif
endif
endif