summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-17 23:56:50 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2022-02-25 01:58:24 +0000
commit803afe6edda17b97e3d12a20585e565a2d2a79a2 (patch)
treeb2b09561899765aa0a21328a250be14ad5357b79 /meson.build
parent1409079eefc04dcb0cab49e02f3cf3cf5e622974 (diff)
downloadcairo-803afe6edda17b97e3d12a20585e565a2d2a79a2.tar.gz
tanis: Remove cairo-cogl
Cogl's upstream is unmaintained, and has been for the past 6 years.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 0 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index ad8fb19c3..3a776f6e9 100644
--- a/meson.build
+++ b/meson.build
@@ -576,21 +576,6 @@ if feature_conf.get('CAIRO_HAS_GL_SURFACE', 0) == 0 and feature_conf.get('CAIRO_
endif
endif
-cogl_dep = dependency('cogl-2.0-experimental',
- version: '>= 1.17.2',
- required: get_option('cogl'),
-)
-if cogl_dep.found()
- deps += [cogl_dep]
-
- feature_conf.set('CAIRO_HAS_COGL_SURFACE', 1)
- built_features += [{
- 'name': 'cairo-cogl',
- 'description': 'Cogl surface backend',
- 'deps': [cogl_dep],
- }]
-endif
-
# Untested
directfb_dep = dependency('directfb', required: get_option('directfb'))
if directfb_dep.found()
@@ -980,7 +965,6 @@ summary({
'OpenGL ES 3.0': feature_conf.get('CAIRO_HAS_GLESV3_SURFACE', 0) == 1,
'DirectFB': feature_conf.get('CAIRO_HAS_DIRECTFB_SURFACE', 0) == 1,
'OpenVG': feature_conf.get('CAIRO_HAS_VG_SURFACE', 0) == 1,
- 'Cogl': feature_conf.get('CAIRO_HAS_COGL_SURFACE', 0) == 1,
}, section: 'Surface Backends', bool_yn: true)
summary({