summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-17 23:44:33 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2022-02-25 01:39:29 +0000
commit81ecff3800e6d71dadbe42d2f29976d9208784a1 (patch)
treeb5edc11b3f70a35905718d0ac7a34204956f7148 /meson.build
parent64ece6d545df015377a1f289829eeea20f5ae019 (diff)
downloadcairo-81ecff3800e6d71dadbe42d2f29976d9208784a1.tar.gz
Remove BeOS support
Nobody cares about BeOS in 2022, and it cannot be built with Meson anyway. Removing the BeOS backend also allows us to drop the dependency on a C++ compiler and simplify the Autotools build considerably by removing all the extra CXX targets.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 74492dcfa..9d5b82b37 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('cairo', 'c', 'cpp',
+project('cairo', 'c',
meson_version: '>= 0.56.0',
version: run_command(find_program('version.py'), check: true).stdout().strip(),
default_options: ['warning_level=2'],
@@ -522,8 +522,6 @@ endif
# Not even trying to port gallium as it depends on drm
-# Not porting BEOS or OS/2 backends either, meson doesn't support those
-
# GL / GLESV2 / GLESV3 are mutually exclusive
gl_backend = get_option('gl-backend')
need_egl_functions = false
@@ -1000,7 +998,6 @@ summary({
'OpenGL': feature_conf.get('CAIRO_HAS_GL_SURFACE', 0) == 1,
'OpenGL ES 2.0': feature_conf.get('CAIRO_HAS_GLESV2_SURFACE', 0) == 1,
'OpenGL ES 3.0': feature_conf.get('CAIRO_HAS_GLESV3_SURFACE', 0) == 1,
- 'BeOS': false,
'DirectFB': feature_conf.get('CAIRO_HAS_DIRECTFB_SURFACE', 0) == 1,
'OpenVG': feature_conf.get('CAIRO_HAS_VG_SURFACE', 0) == 1,
'DRM': feature_conf.get('CAIRO_HAS_DRM_SURFACE', 0) == 1,