summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-05-01 16:55:38 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-05-01 16:55:38 +0100
commit833630979404faae2bd99c59e4e5739e675917f0 (patch)
tree64fa43a6238e4ee21389e0cd1be9561ab7a6eb82 /meson.build
parent8f6cfe41773be1764a0813e6bd8f97e18d5b8cd3 (diff)
downloadcairo-833630979404faae2bd99c59e4e5739e675917f0.tar.gz
meson: Define HAVE_CONFIG_H as a project flag
Precisely what Autotools does, instead of adding it as per-target C argument. Once we remove HAVE_CONFIG_H checks in every source file, we'll be able to drop it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d4f759224..06df7f9c1 100644
--- a/meson.build
+++ b/meson.build
@@ -45,6 +45,9 @@ endif
add_project_arguments('-D_GNU_SOURCE', language: 'c')
+# Autotools compatibility
+add_project_arguments('-DHAVE_CONFIG_H', language: 'c')
+
# Make sure source directory hasn't been configured with autotools
if meson.version().version_compare('>= 0.53')
fs = import('fs')