summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-08-15 19:06:10 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-08-15 19:06:10 +0100
commit8b5e285e26ca126a5ae40211bda074fe460a0614 (patch)
treeaaaecf11c464c1501f5e107294169362419ec264 /meson.build
parent919178f1e952957fd5701874479d86df04baaa99 (diff)
downloadcairo-8b5e285e26ca126a5ae40211bda074fe460a0614.tar.gz
meson: Use warning_level
Instead of using `-Wall` and `-Wextra` as compiler flags, set `warning_level=2` as the default warning option.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d78a5f2d6..2f618f75c 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,7 @@
project('cairo', 'c', 'cpp',
meson_version: '>= 0.54.0',
version: run_command(find_program('version.py'), check: true).stdout().strip(),
+ default_options: ['warning_level=2'],
)
# Keep in sync with configure.ac!
@@ -41,8 +42,6 @@ cc = meson.get_compiler('c')
cflags = []
if cc.get_id() != 'msvc'
cflags += [
- '-Wall',
- '-Wextra',
'-Wmissing-declarations',
'-Werror-implicit-function-declaration',
'-Wpointer-arith',