summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFujii Hironori <Hironori.Fujii@sony.com>2023-02-24 10:58:40 +0900
committerFujii Hironori <Hironori.Fujii@sony.com>2023-02-27 11:55:30 +0900
commit950e3fb45d976e80af99cccd438568da975934d8 (patch)
tree9452885fe59222d9d779c8c92dd276d24eb7f825 /meson.build
parent6a5f2140d78f1ccff8642c33eac3b0a8b86a5723 (diff)
downloadcairo-950e3fb45d976e80af99cccd438568da975934d8.tar.gz
Change the workaround of MinGW dwrite_3.h problem
The DWRITE_COLOR_GLYPH_RUN1 struct definition of the old MinGW dwrite_3.h was invalid. To work around the problem, dw-extra.h defined the correct struct definition and all necessary API from dwrite_3.h. This approach needed to redefine all necessary API. This change added DWRITE_COLOR_GLYPH_RUN1_WORKAROUND struct and use it for IDWriteColorGlyphRunEnumerator1::GetCurrentRun.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 5b6f9ebd5..aceaa3416 100644
--- a/meson.build
+++ b/meson.build
@@ -522,7 +522,6 @@ if host_machine.system() == 'windows'
d2d_header = cpp_compiler.has_header('d2d1.h')
d2d_3_header = cpp_compiler.has_header('d2d1_3.h')
dwrite_header = cpp_compiler.has_header('dwrite.h')
- dwrite_3_header = cpp_compiler.has_header('dwrite_3.h')
wincodec_dep = cpp_compiler.find_library('windowscodecs', required: get_option('dwrite'))
wincodec_header = cpp_compiler.has_header('wincodec.h')
@@ -539,11 +538,6 @@ if host_machine.system() == 'windows'
conf.set('HAVE_D2D1_3_H', 1)
endif
- # Exclude MinGW dwrite_3.h because it has a broken definition of DWRITE_COLOR_GLYPH_RUN1.
- if cpp_compiler.has_header('dwrite_3.h') and cpp_compiler.get_define('__MINGW32__') == ''
- conf.set('HAVE_DWRITE_3_H', 1)
- endif
-
add_project_arguments('-DWINVER=_WIN32_WINNT_WIN10', '-D_WIN32_WINNT=_WIN32_WINNT_WIN10', '-DNTDDI_VERSION=NTDDI_WIN10_RS3', language: ['c', 'cpp'])
else
add_project_arguments('-DWINVER=_WIN32_WINNT_WIN2K', '-D_WIN32_WINNT=_WIN32_WINNT_WIN2K', language: ['c', 'cpp'])