summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorge Matsumura <gmmatsumura01@bvsd.org>2020-08-31 01:36:20 -0600
committerGeorge Matsumura <gmmatsumura01@bvsd.org>2020-09-05 12:15:57 +0000
commit9a3ad1df1cdca3559d0102918b7527005605df1a (patch)
treed508e1a8c5b3d67343efc46995fababd388d29a2 /meson.build
parent3b1bf9d6d3cbf2074eb347bc4cb33704f57d800d (diff)
downloadcairo-9a3ad1df1cdca3559d0102918b7527005605df1a.tar.gz
build: Include correct poll.h
Including sys/poll.h when poll.h is available produces a compile warning on some systems, but only sys/poll.h is present on others such as AIX. This makes sure the most suitable poll.h is included in each situation. Signed-off-by: George Matsumura <gmmatsumura01@bvsd.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9a78591bc..fddb3a28c 100644
--- a/meson.build
+++ b/meson.build
@@ -44,6 +44,7 @@ check_headers = [
['signal.h'],
['sys/stat.h'],
['sys/socket.h'],
+ ['poll.h'],
['sys/poll.h'],
['sys/un.h'],
['sched.h', {'check-funcs': ['sched_getaffinity']}],